Migration und Update auf die JoomGallery 1.5

Zuletzt aktualisiert am Donnerstag, 09. Februar 2012 15:47

Seit der PonyGallery ML war es für uns immer das Ziel, die Anwender älterer Versionen 'mitzunehmen' und nicht im Regen stehen zu lassen, wenn eine neue Version der Galerie veröffentlicht wurde. Zum Beispiel war es mit dem UpdateZip der PonyGallery ML möglich, jede ältere Version auf den Stand der letzten produktiven Version 2.5.1. zu bringen.

Mit der Veröffentlichung der JoomGallery bieten wir mit dem Migrationsmanager eine Übernahme der Bilder aus der PonyGallery ML an. Auch für die JoomGallery 1.0.0 stand ein Updatezip zur Verfügung, um ältere Versionen vor der 1.0.0 zu aktualisieren.

Mit der JoomGallery 1.5.5 ist ein Update einer JoomGallery der Version 1.0 und neuer einfach möglich. Entweder wird die Autoupdate-Funktion im Adminmenü der Galerie genutzt oder -wenn diese nicht genutzt werden kann- das Zip aus unserem Downloadbereich geladen und über den Erweiterungsmanager von Joomla! installiert.
Wichtig: Die bestehende Installation der JoomGallery darf vorher nicht deinstalliert werden.

Bei dem Updateprozess wird erkannt, ob schon eine JoomGallery (ab Version 1.0) vorhanden ist und auf den neuesten Stand gebracht. Die schon vorhandenen Bilder, Kategorien usw. bleiben erhalten. Details zu dem Updateprozess findet Ihr in diesem Artikel.


In den folgenden Szenarien wird als Zielsystem die derzeit aktuelle JoomGallery 1.5.5 unter Joomla 1.5.x angenommen. Aus Sicherheitsgründen solltet Ihr kein älteres Joomla! 1.5.x einsetzen und ggf. vorher auf die aktuelle Version updaten.

Vor folgenden Aktionen sollte ein neues Backup der Datenbank und ggf. der Bilddateien angelegt werden:


Von PonyGallery ML 2.5.1 oder kleiner unter Joomla! 1.0.x

Von PonyGallery ML unter Joomla! 1.0


Von PonyGallery ML ported 2.5.1 (nativ, von Chraneco)
unter Joomla! 1.5.x

Von PonyGallery ML unter Joomla! 1.5


Von JoomGallery 1.0.0 unter Joomla! 1.5.x
mit aktiviertem Legacy Plugin

Von JoomGallery 1.0 unter Joomla! 1.5

Installation der Komponente (1.5) über das Backend von Joomla! (Erweiterungsmanager). Damit wird die JoomGallery 1.0.0 automatisch auf die aktuelle JoomGallery 1.5.5 upgedated. Es werden dabei Änderungen in der Datenbank vorgenommen, überflüssige Dateien entfernt und die anderen Dateien ggf. aktualisiert.


Von JoomGallery 1.5
unter Joomla! 1.5.x

Von JoomGallery 1.5 unter Joomla! 1.5

Installation der Komponente (1.5) über das Backend von Joomla! (Erweiterungsmanager). Damit wird die JoomGallery 1.5.5 automatisch auf die neue Version aktualisiert. Es werden dabei Änderungen in der Datenbank vorgenommen, überflüssige Dateien entfernt und die anderen Dateien ggf. aktualisiert.


Diese FAQ wird ständig aktualisiert. Wir wünschen Euch viel Erfolg bei der Migration und dem Update. Für Fragen stehen wir Euch im Forum zur Verfügung